Marketplace

zoom_in

D-Link ADSL2+ Modem Router (DSL-520B)

€34.79
storefront Visit Jacinthe Welch's Store
Port: 1x RJ-11 ADSL, 1x RJ-45 10/100BASE-TX Ethernet LAN Port with auto MDI/MDIX Routing Information Protocol (RIP, RIPv2) RFC 1058, RFC 1723, Network Address Translation (NAT) RFC 1631 Get high-speed ADSL speed Firewall protection & Qos Safety Certification: CSA International; CE; RoHs Compliant